[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bacula-devel] Winbacula VSS errors but job still terminates with OK


I'm in the process of testing Bacula 2.3.22 (SVN) server and I noticed when I
backup winbacula 2.2.10-b4 client (windows 2003 r2 sp2 32bit) 50% of the
backup jobs fail with "ERR=Access is denied" error..

bconsole says this:

JobId 5: Generate VSS snapshots. Driver="VSS Win 2003", Drive(s)="C"
JobId 5:      Could not stat C:/Program Files: ERR=Access is denied.

My test backup job for that client is trying to backup only "c:\program files".
The same error seems to happen also if I try to backup some other directory.

Winbacula runs as SYSTEM user on Windows. Next time when I run the job it
works just fine.. and the next time it fails.. and the next time it works. 

Exactly every second works and every second fails.. 

I don't know if Windows VSS goes into some bad state because of Bacula or if
that's some problem with Windows itself.. or some application installed on
Windows. Windows event log doesn't have any errors or warnings.

The alarming thing is that when the job fails with that "ERR=Access is denied" 
zero files and zero mbytes are backup up.. but the job status is still 
"Backup OK -- with warnings".. 

I think that's definitely not OK.. the whole backup has failed but the
status is still "OK".. 

-- Pasi

This SF.net email is sponsored by: Microsoft
Defy all challenges. Microsoft(R) Visual Studio 2008.
Bacula-devel mailing list

This mailing list archive is a service of Copilotco.