[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bacula-devel] win32 build problem under Debian Lenny - texinfo


I'm attempting a win32 cross compile under Linux so I can do some plugin
testing, but I'm getting an error.

It looks like binutils-2.16.91-20060119-1-src.tar.gz has to have a valid
version of texinfo, even though at first glance it would cope with it
being missing.

Unfortunately, a 'valid version' means newer than 4.2, but the test is
broken such that 4.11 (which Debian Lenny is using) isn't a valid
version, so things break.

The test is in the 'configure' file and is to egrep the output of
--version with "egrep 'texinfo[^0-9]*([1-3][0-9]|4\.[2-9]|[5-9])'".

This is obviously a problem with upstream (is there a newer binutils we
can use?) but should probably be documented in README.mingw32...

Unless someone has a better solution, I'll try and put together a patch
to fix it.

James

-------------------------------------------------------------------------
This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK & win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
http://moblin-contest.org/redirect.php?banner_id=100&url=/
_______________________________________________
Bacula-devel mailing list
Bacula-devel@xxxxxxxxxxxxxxxxxxxxx
https://lists.sourceforge.net/lists/listinfo/bacula-devel


This mailing list archive is a service of Copilotco.