[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Bacula-devel] [Bacula-users] bacula 2.4.1b1 waiting for already mounted volume


On Friday 04 July 2008 10:50:52 Arno Lehmann wrote:
> Hi,
>
> 04.07.2008 10:27, Kern Sibbald wrote:
> > If you are new to Bacula and/or you are having support problems, you will
> > probably get much better answers from the bacula-users list.  See
> > www.bacula.org -> Support.  The bacula-devel list is specifically for
> > development issues or issues that are clearly known to be a beta problem.
>
> Well, we have discussed this issue at -users and I recommended to ask
> here :-)

It would have been better had he mentioned this, and for future cases, I 
recommend that you explicitly tell them to mention that and point me to the 
previous email -- he just said that he was a newbie.  

>
> The Bacula version running is 2.4.1b1, upgraded from 2.4.0.
>
> With 2.4.0, no problems.
>
> After the upgrade the mentioned problem arose.
>
> I trim the report below a bit to better show what I think is problematic.
>
> Without further checking, I got the impression that the volume
> selection / reservation seems to be involved - and I believe you did
> some work there.
>
> My conclusion: Looks like a new "feature" of the reworked SD code, and
> you might prefer to know about it before releasing a 2.4.2 based on
> this version...

Yes, I would like to know.  If he is doing a restore, it is possible that this 
is a 2.4.1-b1 bug, but it would have been much better to see the output 
leading up to the problem -- including any job output he might have received.

>
> > However, be aware that the information you sent is not complete enough
> > for them to give a good answer.  I suspect that you either lost or forgot
> > to define the slot numbers in the catalog.
>
> Assuming Nils didn't manually modify the catalog, Bacula itself lost
> the slot numbers :-)
>
> >  Since your volume listing is
> > clipped, I cannot confirm it.
> >
> > Thanks for trying the beta version -- good luck on getting it going.
> >
> > Best regards,
> >
> > Kern
> >
> > On Friday 04 July 2008 09:49:11 Nils Blanck-Wehde wrote:
> >> Hello,
>
> ...
>
> >> Bacula started a job that's supposed to be stored on tape, chose exactly
> >> the right volume "CNV762" from the pool, purged and recycled it. The
> >> tape was even loaded correctly from the right slot into the drive.
>
>                   ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
> Bacula knew about the slot.

He didn't explain what kind of job.  If you read what he says more carefully 
than I did the first time, it looks like he is trying to do a restore, but it 
is unclear.  Whether it is a backup or restore makes a lot of difference.

>
> >> Here's *list volumes of that pool:
> >> |      28 | CNV762     | Recycle   |       1 |             1 |        0
> >> |       10,800 |
> >> |      29 | CNV763     | Used      |       1 | 3,982,261,248 |        4
> >> |       10,800 |
> >> |      30 | CNV764     | Used      |       1 | 3,545,837,568 |        4
> >> |       10,800 |
> >> |      43 | CNV761     | Used      |       1 | 3,982,841,856 |        4
> >> |        3,600 |
> >>
> >> +---------+------------+-----------+---------+---------------+----------

I don't recognize the above output -- it vaguely looks like a "list volumes", 
but it is seriously truncated so confusing and if the slot numbers are there, 
they are not obvious to me.

> >>+--
> >>
> >> Now, the job is waiting for the right volume to be mounted, which is
> >> already in the drive.
> >> The storage-device's status is:
> >>
> >> Device status:
> >> Autochanger "QS3DLT" with devices:
> >>   "DLT-Drive-1" (/dev/st0)
> >> Device "FileStorage_SATA-RAID1-MD1" (/var/bacula/File-Storage) is not
> >> open. Device "DLT-Drive-1" (/dev/st0) open but no Bacula volume is
> >> currently mounted.
> >>    Device is BLOCKED waiting for mount of volume "CNV762",
> >>       Pool:        Weekly_Full_Backup_to_DLT
> >>       Media type:  DLT-VS1
> >>    Slot 2 is loaded in drive 0.
> >>    Total Bytes Read=322,560 Blocks Read=5 Bytes/block=64,512
> >>    Positioned at File=0 Block=0
> >> Device "DVD Writer" (/dev/hda) is not open.
> >> ====
> >>
> >> In Use Volume status:
> >> CNV762 on device "DLT-Drive-1" (/dev/st0)
> >>    Reader=0 writers=0 devres=1 volinuse=1
>
> All the information needed is there - CNV762 is in DLT-Drive-1,
> DLT-Drive-1 wants this volume.

I recommend that he either back up to 2.4.0 or that he pull the latest svn, 
which has a few 2.4.1-b1 mount problems corrected.

Regards,

Kern


-------------------------------------------------------------------------
Sponsored by: SourceForge.net Community Choice Awards: VOTE NOW!
Studies have shown that voting for your favorite open source project,
along with a healthy diet, reduces your potential for chronic lameness
and boredom. Vote Now at http://www.sourceforge.net/community/cca08
_______________________________________________
Bacula-devel mailing list
Bacula-devel@xxxxxxxxxxxxxxxxxxxxx
https://lists.sourceforge.net/lists/listinfo/bacula-devel


This mailing list archive is a service of Copilotco.