[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Bacula-devel] bacula-2.4.2 rpm release to sourceforge


Dear all,

In the spec file used for making Bacula RPM, in the post install script we need to find the absolute path to the location of the RPM.

For e.g if the RPM is located in /etc/Riyas/baculaxxxx.rpm  during installation in the post install script we need to find the absolute
path to the RPM file..ie; /etc/Riyas/baculaxxxx.rpm..  This is because we need to read something from the lead header of RPM in the post 
install script.

Any and all help appreciated..

Regards,
Riyas

-----Original Message-----
From: bacula-devel-bounces@xxxxxxxxxxxxxxxxxxxxx [mailto:bacula-devel-bounces@xxxxxxxxxxxxxxxxxxxxx] On Behalf Of Scott Barninger
Sent: Tuesday, August 05, 2008 4:30 AM
To: Carlos André
Cc: Bacula-Devel; Bacula-Users; Bacula-Announce
Subject: Re: [Bacula-devel] bacula-2.4.2 rpm release to sourceforge

Hello,

I have just uploaded corrected bat packages for fc8/fc9. Please download
bacula-bat-2.4.2-2.fc*.i386.rpm. Sorry for the inconvenience, the
foibles of copy and paste and forget to edit the %if statement.

n Mon, 2008-08-04 at 11:20 -0300, Carlos André wrote:
> Why bacula-bat fc8 asks for glibc >= 2.8 ??
> # rpm -Uvh bacula-bat-2.4.2-1.fc8.i386.rpm
> erro: Failed dependencies:
>         glibc >= 2.8 is needed by bacula-bat-2.4.2-1.i386
> 
> 
> On Sun, Aug 3, 2008 at 2:47 PM, Scott Barninger <scott@xxxxxxxxxxxxx>
> wrote:
>         Bacula-2.4 RPM Release Notes
>         03 August 2008
>         D. Scott Barninger
>         <barninger at fairfieldcomputers dot com>
>         
>         Release 2.4.2-1
>         
>         This release incorporates a number of significant changes
>         since 1.38.
>         
>         These release notes refer to the rpm packaging only.
>         Please refer to the release notes and changelog in the
>         tarball or on sourceforge for complete information on all
>         changes.
>         
>         
>         *****************
>         * Miscellaneous *
>         *****************
>         
>         Added build target for su110
>         
>         Added build target for fc9
>         
>         File location changes for compatibility with FHS.
>         
>         Force stripping of binaries for SuSE packages.
>         
>         Fixed bug 1037.
>         
>         Added nobuild_mtx switch to supress build of mtx package.
>         
>         Added missing files now required by the rescue configure
>         script.
>         
>         Corrected dist target for rhel5.
>         
>         Corrected QT dependency name for RedHat flavors.
>         
>         Added fix for RHEL5 64 bit QT paths.
>         
>         Added build target for su103.
>         
>         Added build targets for rhel5 and clones.
>         
>         Build target added for Scientific Linux (RHEL clone) thanks to
>         Jon
>         Peatfield.
>         
>         Merged Otto Mueller's patch changing some directory locations
>         for FHS
>         compatibility
>         but retaining the script directory as /etc/bacula.
>         
>         gnome-console and wxconsole have been renamed to
>         bgnome-console and
>         bwx-console
>         respectively.
>         
>         *****************************************
>         * Buffer Overflow Error and Crash in fd *
>         *****************************************
>         
>         Fedora 8/9 now set -D_FORTIFY_SOURCE=2 as default compiler
>         option. This
>         will probably be true on other platforms as they move to glibc
>         >= 2.7.
>         This
>         causes a false "buffer overflow detected" error and crash in
>         bacula-fd
>         and
>         other executables.
>         
>         To avoid this problem a workaround for Redhat platforms is to
>         set the
>         CFLAGS
>         in your ~/.rpmmacros file as follows:
>         
>         # uncomment for bacula
>         #%__global_cflags -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=0
>         -fno-exceptions -fno-strict-aliasing -fno-rtti
>         
>         For SuSE platforms set as follows in your ~/.rpmrc file:
>         
>         optflags: i586 -O2 -g -m32 -march=i586 -mtune=i686
>         -fmessage-length=0
>         -D_FORTIFY_SOURCE=0
>         optflags: x86_64 -O2 -g -fmessage-length=0 -D_FORTIFY_SOURCE=0
>         
>         See the discussion thread on bacula-devel for more
>         information:
>         http://sourceforge.net/search/?ml_name=bacula-devel&type_of_search=mlists&group_id=50727&words=%22buffer+overflow+detected%22
>         
>         ***************************
>         * bat (Bacula Admin Tool) *
>         ***************************
>         
>         A new subpackage has been added for the new bat QT-based GUI
>         administration tool.
>         This requires QT >= 4.2
>         
>         --define "build_bat 1"
>         
>         If you encounter problems building the bat package on
>         platforms where
>         you do have the proper QT4 support (QT >= 4.2) it may be
>         necessary to
>         adjust your $QTDIR and $PATH variables. On Fedora 8/9 it was
>         necessary
>         to:
>         
>         export QTDIR=/usr/lib/qt4;export PATH=/usr/lib/qt4/bin:
>         $PATH;rpmbuild
>         blah...
>         
>         *******************************************
>         * Gnome console dropped on some platforms *
>         *******************************************
>         
>         The gconsole package has been dropped on older gnome platforms
>         (gtk+ <
>         2.4).
>         Changes in the gnome api and code produced by Glade no longer
>         build.
>         In addition, the tray monitor now fails to build on < 2.10
>         platforms.
>         gconsole is now not built on the following platforms:
>         rh7, rh8, rh9, rhel3 (and clones), fc1, fc3, fc4, mdk, su9,
>         su10
>         
>         ********************************
>         * Third party packager support *
>         ********************************
>         
>         A new build tag added to support third party packagers to
>         replace the
>         information in the Packager: tag in the rpm. Invoking
>         --define "contrib_packager Your Name <your-emmail@xxxxxxxx>"
>         will substitute your packager identification.
>         
>         Users interested in building packages for platforms not
>         normally
>         published
>         should examine the platforms/contrib-rpm directory in the
>         source code.
>         
>         *******************************
>         * Option to build client only *
>         *******************************
>         
>         A build define to build the client rpm package only added.
>         This turns
>         off all database builds, gnome console and wxconsole.
>         --define "build_client_only 1"
>         
>         ************************
>         * Python support added *
>         ************************
>         
>         Support for compiling with python scripting support added.
>         This is off
>         by default but can be enabled with:
>         --define "build_python 1"
>         Released binary packages are built with python support.
>         
>         *******************
>         * Database update *
>         *******************
>         
>         The 2.x release requires an update to the bacula database
>         structure
>         from version 9 to version 10. A pre-install routine has been
>         added to
>         check for databases older than 9. In that event the install
>         will exit
>         with an error message indicating that the database must be
>         updated to
>         version 9 before installing this upgrade. Scripts for updating
>         older
>         database formats are available for download in the
>         bacula-updatedb
>         rpm package. In the event a version 9 database is detected a
>         post-install
>         routine will update the database after creating a backup file
>         in the
>         bacula working directory.
>         
>         ******************
>         * SQLite Upgrade *
>         ******************
>         
>         For users of the sqlite package, from 2.2.7 onward sqlite3
>         replaces
>         sqlite2. Your sqlite2 database file
>         (/var/lib/bacula/bacula.db) is not
>         compatible with sqlite3. During an upgrade the pre-install
>         script will
>         check for this situation. If found it will dump your catalog
>         data to
>         the
>         file /var/lib/bacula/bacula_backup.sql, rename your old
>         catalog file to
>         /var/lib/bacula/bacula.db.old, and exit. You should then
>         re-run the rpm
>         upgrade. After the upgrade is complete restore your catalog
>         data with
>         the following commands (as root):
>         
>         /etc/bacula/drop_sqlite3_tables
>         cd /var/lib/bacula
>         /usr/lib/bacula/sqlite/sqlite3 $* bacula.db <
>         bacula_backup.sql
>         chown bacula.bacula bacula.db
>         
>         ******************
>         * Platform Notes *
>         ******************
>         
>         The spec file currently supports building on the following
>         platforms:
>         
>         # RedHat builds
>         --define "build_rh7 1"
>         --define "build_rh8 1"
>         --define "build_rh9 1"
>         
>         # Fedora Core build
>         --define "build_fc1 1"
>         --define "build_fc3 1"
>         --define "build_fc4 1"
>         --define "build_fc5 1"
>         --define "build_fc6 1"
>         --define "build_fc7 1"
>         --define "build_fc8 1"
>         --define "build_fc9 1"
>         
>         # Whitebox Enterprise build
>         --define "build_wb3 1"
>         
>         # RedHat Enterprise builds
>         --define "build_rhel3 1"
>         --define "build_rhel4 1"
>         --define "build_rhel5 1"
>         
>         # CentOS build
>         --define "build_centos3 1"
>         --define "build_centos4 1"
>         --define "build_centos5 1"
>         
>         # Scientific Linux build
>         --define "build_sl3 1"
>         --define "build_sl4 1"
>         --define "build_sl5 1"
>         
>         # SuSE build
>         --define "build_su9 1"
>         --define "build_su10 1"
>         --define "build_su102 1"
>         --define "build_su103 1"
>         --define "build_su110 1"
>         
>         # Mandrake 10.x build
>         --define "build_mdk 1"
>         
>         # Mandriva build
>         --define "build_mdv 1"
>         
>         **************************
>         * Database build options *
>         **************************
>         
>         Database support (must select one or build client only)
>         
>         MySQL support:
>         --define "build_mysql 1"
>         # OR if using mysql 4.x define this
>         # currently: Mandrake 10.x, SuSE 9.x & 10.0, RHEL4, fc4
>         --define "build_mysql4 1"
>         # OR if using mysql 5.x define this
>         # currently: SuSE 10.1 and higher, fc5 and higher
>         --define "build_mysql5 1"
>         
>         PostgreSQL support:
>         --define "build_postgresql 1"
>         
>         Sqlite support:
>         --define "build_sqlite 1"
>         
>         ***********************
>         * Other build options *
>         ***********************
>         
>         Supress build of mtx package:
>         --define "nobuild_mtx 1"
>         
>         Supress build of Gnome Console:
>         --define "nobuild_gconsole 1"
>         
>         Enable X86-64 support
>         --define "build_x86_64 1"
>         
>         This build switch remains but should no longer be necessary.
>         The
>         configure script
>         was adjusted in the 1.39 development series to correctly
>         detect the
>         location of
>         64 bit libraries.
>         
>         Enable wxconsole:
>         --define "build_wxconsole 1"
>         
>         Enable bat:
>         --define "build_bat 1"
>         
>         Enable python support:
>         --define "build_python 1"
>         
>         Build the client package only:
>         --define "build_client_only 1"
>         
>         **********************************
>         * Current binary package support *
>         **********************************
>         
>         D. Scott Barninger <barninger at fairfieldcomputers dot com>
>         el3 i386
>         fc8 i386
>         fc9 i386
>         su103 i586
>         su110 i586
>         
>         Felix Schwarz <felix dot schwarz at web dot de>
>         fc6 i386
>         fc6 x86_64
>         fc7 i386
>         fc7 x86_64
>         el4 i386
>         el4 x86_64
>         el5 i386
>         el5 x86_64
>         
>         PattiMichelle Sheaffer <pattimichelle at pattimichelle dot
>         com>
>         su103 x86_64
>         su110 x86_64
>         
>         Mandriva packages are available in the distribution contrib
>         repository.
>         
>         ***************************
>         * Changelog since 1.38.11 *
>         ***************************
>         * Sat Jun 28 2008 D. Scott Barninger
>         <barninger@xxxxxxxxxxxxxxxxxxxxxx>
>         - add su110 target
>         * Sat May 24 2008 D. Scott Barninger
>         <barninger@xxxxxxxxxxxxxxxxxxxxxx>
>         - add fc9 target
>         * Sun Mar 30 2008 D. Scott Barninger
>         <barninger@xxxxxxxxxxxxxxxxxxxxxx>
>         - FHS compatibility changes
>         * Sat Feb 16 2008 D. Scott Barninger
>         <barninger@xxxxxxxxxxxxxxxxxxxxxx>
>         - remove fix for false buffer overflow detection with glibc >=
>         2.7
>         - eliminate use of configure macro
>         * Sat Feb 09 2008 D. Scott Barninger
>         <barninger@xxxxxxxxxxxxxxxxxxxxxx>
>         - fix for false buffer overflow detection with glibc >= 2.7
>         * Sun Jan 27 2008 D. Scott Barninger
>         <barninger@xxxxxxxxxxxxxxxxxxxxxx>
>         - 2.2.8 release
>         - add debug package for SuSE
>         * Sat Jan 12 2008 D. Scott Barninger
>         <barninger@xxxxxxxxxxxxxxxxxxxxxx>
>         - 2.2.8 beta release
>         - fix bug 1037
>         - add fc8 target
>         * Fri Dec 28 2007 D. Scott Barninger
>         <barninger@xxxxxxxxxxxxxxxxxxxxxx>
>         - add nobuild_mtx switch
>         * Sat Nov 17 2007 D. Scott Barninger
>         <barninger@xxxxxxxxxxxxxxxxxxxxxx>
>         - switch to sqlite3
>         * Sun Nov 11 2007 D. Scott Barninger
>         <barninger@xxxxxxxxxxxxxxxxxxxxxx>
>         - add new files required by rescue makefile
>         * Sat Nov 10 2007 D. Scott Barninger
>         <barninger@xxxxxxxxxxxxxxxxxxxxxx>
>         - add su103 build target
>         * Sun Nov 04 2007 D. Scott Barninger
>         <barninger@xxxxxxxxxxxxxxxxxxxxxx>
>         - fix dist defines for rhel5 and clones
>         - fix rhel broken 64 bit QT4 paths
>         - rh qt4 packages don't provide qt so fix that too
>         * Mon Oct 29 2007 D. Scott Barninger
>         <barninger@xxxxxxxxxxxxxxxxxxxxxx>
>         - correct ownership when creating sqlite db file in post
>         script
>         * Sun Sep 16 2007 D. Scott Barninger
>         <barninger@xxxxxxxxxxxxxxxxxxxxxx>
>         - fix disable-batch-insert
>         * Fri Sep 14 2007 D. Scott Barninger
>         <barninger@xxxxxxxxxxxxxxxxxxxxxx>
>         - 2.2.4 release
>         - turn off gconsole build for fc3, tray monitor fails to build
>         - add new files for mtx package (09Sep07 depkgs update)
>         * Sat Sep 08 2007 D. Scott Barninger
>         <barninger@xxxxxxxxxxxxxxxxxxxxxx>
>         - add --disable-batch-insert for older platforms
>         - add build targets for rhel5 and clones
>         * Mon Sep 03 2007 D. Scott Barninger
>         <barninger@xxxxxxxxxxxxxxxxxxxxxx>
>         - 2.2.1 release
>         - turn off gconsole build for su10 & fc4, tray monitor fails
>         to build
>         * Sat Jul 14 2007 D. Scott Barninger
>         <barninger@xxxxxxxxxxxxxxxxxxxxxx>
>         - 2.1.26 add make of qwt in depkgs for bat
>         * Sat Jun 02 2007 D. Scott Barninger
>         <barninger@xxxxxxxxxxxxxxxxxxxxxx>
>         - upgrade Qt requirement for bat to 4.2
>         * Sun May 06 2007 D. Scott Barninger
>         <barninger@xxxxxxxxxxxxxxxxxxxxxx>
>         - add fc7 build target
>         * Sun Apr 29 2007 D. Scott Barninger
>         <barninger@xxxxxxxxxxxxxxxxxxxxxx>
>         - 2.1.8
>         - gnome-console now bgnome-console
>         - wxconsole now bwx-console
>         - add build option for bat
>         * Sat Apr 08 2007 D. Scott Barninger
>         <barninger@xxxxxxxxxxxxxxxxxxxxxx>
>         - merge Otto Mueller's patch but keep script dir set
>         to /etc/bacula
>         - add build tag for Scientific Linux per Jon Peatfield
>         <J.S.Peatfield@xxxxxxxxxxxxxxx>
>         * Tue Mar 27 2007 Otto Mueller <otto.mueller@xxxxxxxxxxxx>
>         - adjust directory locations for FHS-compatibility
>          sysconf_dir (/etc/bacula), script_dir (/usr/lib/bacula),
>          working_dir (/var/lib/bacula) and pid_dir (/var/run)
>         * Mon Feb 26 2007 D. Scott Barninger
>         <barninger@xxxxxxxxxxxxxxxxxxxxxx>
>         - add SuSE 10.2 target
>         * Sat Jan 20 2007 D. Scott Barninger
>         <barninger@xxxxxxxxxxxxxxxxxxxxxx>
>         - correct bug 752
>         - set query.sql as config file
>         - correct bug 754
>         * Sun Jan 14 2007 D. Scott Barninger
>         <barninger@xxxxxxxxxxxxxxxxxxxxxx>
>         - 2.0.1 release
>         - change determination of gcc version per patch from Marc
>         Hennes
>         - move BuildRequire for atk-devel to gnome only builds
>         - add fc6 build tag
>         * Sat Jan 06 2007 D. Scott Barninger
>         <barninger@xxxxxxxxxxxxxxxxxxxxxx>
>         - 2.0.0 release
>         * Sun Oct 15 2006 D. Scott Barninger
>         <barninger@xxxxxxxxxxxxxxxxxxxxxx>
>         - 1.39.26 remove create_sqlite_database.in.patch
>         * Sun Sep 24 2006 D. Scott Barninger
>         <barninger@xxxxxxxxxxxxxxxxxxxxxx>
>         - change ownership of working_dir on server packages to
>         bacula.bacula so
>         that
>         - bacula-sd can create bootstrap files
>         * Sat Sep 02 2006 D. Scott Barninger
>         <barninger@xxxxxxxxxxxxxxxxxxxxxx>
>         - 1.39.22 remove separate cd and make of manpages the main
>         Makefile does
>         it now
>         * Sun Aug 06 2006 D. Scott Barninger
>         <barninger@xxxxxxxxxxxxxxxxxxxxxx>
>         - fix manpages file extension for mdk
>         * Sat Aug 05 2006 D. Scott Barninger
>         <barninger@xxxxxxxxxxxxxxxxxxxxxx>
>         - bug 648 re-enable and update sqlite patches
>         - 1.39.18 changes
>         - updatedb 9 to 10
>         - install man pages
>         - lock out gconsole build for gtk+ < 2.4
>         * Mon Jul 17 2006 D. Scott Barninger
>         <barninger@xxxxxxxxxxxxxxxxxxxxxx>
>         - move pango-devel BuildRequires into gconsole only build
>         * Sat Jul 15 2006 D. Scott Barninger
>         <barninger@xxxxxxxxxxxxxxxxxxxxxx>
>         - add provides and conflicts for standard suse packages
>         - add third party packager tag support
>         - add build_client_only tag
>         - remove bsmtp from client package
>         - add bacula-ctl-fd to client package
>         * Thu Jul 13 2006 D. Scott Barninger
>         <barninger@xxxxxxxxxxxxxxxxxxxxxx>
>         - fix directory creation when wxconsole and not gconsole
>         * Tue Jul 04 2006 D. Scott Barninger
>         <barninger@xxxxxxxxxxxxxxxxxxxxxx>
>         - add check to buildrequires to make sure libstdc++ version
>         matches gcc
>         * Mon Jul 03 2006 D. Scott Barninger
>         <barninger@xxxxxxxxxxxxxxxxxxxxxx>
>         - add python build support
>         - fix LDFLAGS declarations
>         * Sun Jul 02 2006 D. Scott Barninger
>         <barninger@xxxxxxxxxxxxxxxxxxxxxx>
>         - add requires for standard compiler toolchain
>         - move version and release tags up
>         - move patches up
>         - add docs_version tag
>         
>         
>         -------------------------------------------------------------------------
>         This SF.Net email is sponsored by the Moblin Your Move
>         Developer's challenge
>         Build the coolest Linux based applications with Moblin SDK &
>         win great prizes
>         Grand prize is a trip for two to an Open Source event anywhere
>         in the world
>         http://moblin-contest.org/redirect.php?banner_id=100&url=/
>         _______________________________________________
>         Bacula-devel mailing list
>         Bacula-devel@xxxxxxxxxxxxxxxxxxxxx
>         https://lists.sourceforge.net/lists/listinfo/bacula-devel
> 
> 


-------------------------------------------------------------------------
This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK & win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
http://moblin-contest.org/redirect.php?banner_id=100&url=/
_______________________________________________
Bacula-devel mailing list
Bacula-devel@xxxxxxxxxxxxxxxxxxxxx
https://lists.sourceforge.net/lists/listinfo/bacula-devel
-------------------------------------------------------------------------
This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK & win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
http://moblin-contest.org/redirect.php?banner_id=100&url=/
_______________________________________________
Bacula-devel mailing list
Bacula-devel@xxxxxxxxxxxxxxxxxxxxx
https://lists.sourceforge.net/lists/listinfo/bacula-devel


This mailing list archive is a service of Copilotco.