[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Bacula-devel] ctest Finds No Tests


On Thursday 15 May 2008 10:31:18 Allan Black wrote:
> I am trying to run the regression tests:
>
> ctest -D Experimental -R all-non-root:
>
> but I get the message:
>
> No tests were found!!!
>
> I have searched my copy of the regress directory, but cannot
> find any reference to all-non-root. Perhaps I am trying to
> run a test set which has recently been removed .... is this
> the case?

Please read <bacula>/regress/README.ctest  It explains the details of setting 
up and running the tests.  It should help you a lot since we have scripts 
that simplify everything ...

I *really* appreciate anyone and everyone who wants to setup running automatic 
nightly running of the tests.  It *really* helps us find and eliminate 
problems with the code -- it is especially important to have as many people 
running these tests, because even if you are running them on the same OS as 
someone else, there always seem to be subtle differences that show up because 
of different hardware (memory size, CPU speed, chipset, ...).

Best regards,

Kern



>
> Allan
>
> -------------------------------------------------------------------------
> This SF.net email is sponsored by: Microsoft
> Defy all challenges. Microsoft(R) Visual Studio 2008.
> http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/
> _______________________________________________
> Bacula-devel mailing list
> Bacula-devel@xxxxxxxxxxxxxxxxxxxxx
> https://lists.sourceforge.net/lists/listinfo/bacula-devel



-------------------------------------------------------------------------
This SF.net email is sponsored by: Microsoft 
Defy all challenges. Microsoft(R) Visual Studio 2008. 
http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/
_______________________________________________
Bacula-devel mailing list
Bacula-devel@xxxxxxxxxxxxxxxxxxxxx
https://lists.sourceforge.net/lists/listinfo/bacula-devel


This mailing list archive is a service of Copilotco.